Xiaomi Mi A1: pomalá Wi-Fi při zapnutém Bluetooth a GPS?

Není to ještě ani týden, co čínský výrobce úspěšně vyřešil problémy s nefunkční LTE konektivitou na Xiaomi Mi A1 po aktualizaci na Android 9 Pie a máme tu možná další problém. Je jím pomalá Wi-Fi při zapnutém Bluetooth a GPS. Pojďme se podívat na to, co ohlásili naši čtenáři.

Začněme tím, že Xiaomi Mi A1 je telefon z projektu Android One. Místo nadstavby MIUI má tedy čistý Android, který by měl být zárukou častých a rychlých aktualizací. V současnosti jsou již na trhu nástupnické modely: prakticky stejně vybavený Mi A2 Lite (v našem e-shopu za 3990 Kč) a výkonnější Mi A2 (ten u nás začíná na 4990 Kč).

Pomalá Wi-Fi při zapnutém Bluetooth a GPS

Na první pohled se může zdát, že Xiaomi Mi A1 je extrémně problematický mobil. Přeci jen za uplynulý rok museli jeho majitelé řešit problémy s drancováním baterie, nefungující LED, během jedné aktualizace dokonce došlo na mazání historie SMS.

Opak je pravdou – telefony řady Mi A1 jsou velmi dobrá zařízení, která svou příznivou cenou, slušnou hardwarovou výbavou a čistým Androidem přilákala mnoho zákazníků. Dnes je vlastní i uživatelé, pro které byla značka Xiaomi ještě nedávno velkou neznámou. Proto se také o případných problémech velice rychle začne mluvit.

Pomalá Wi-Fi se některým uživatelům projevovala ještě před aktualizací, tedy s Androidem 8 Oreo. Podle některých se ale potíže po aktualizaci na Android 9 Pie zvýraznily. Jako jeden z prvních hlásil problémy tohoto typu Jenda85 už 29. prosince.

Kdy a jak se závada projevuje?

Den poté potvrdil potíže další majitel Xiaomi Mi A1, který se v komentářích podepisuje jako Viktor. Jako první také zmínil kombinaci, při které se pomalá Wi-Fi projevuje: pokud je současně zapnutá poloha a Bluetooth. Jestliže je zapnutá jen poloha, nebo pouze Bluetooth, jsou přenosy přes Wi-Fi rychlé.

9. ledna potvrdil čtenář Jenda85 stav věci: při zapnuté poloze a Bluetooth jsou data přes Wi-Fi pomalá, v jakékoli jiné kombinaci probíhají přenosy přes bezdrátovou síť obvyklou očekávanou rychlostí. To samé chování zaznamenal a ohlásil o den později i čtenář Ren, zatímco erpe doplnil, že se s těmito problémy potýká už od Androidu 8 Oreo.

Chování zjevně není způsobeno nějakou nekompatibilitou či chybou během aktualizace. Mnozí z postižených provedli reset do továrního nastavení a situace po něm byla naprosto stejná. Přenosové rychlosti při zapnutém Bluetooth a GPS se pohybují na třetině až pětině hodnot ve srovnání s tím, když je alespoň jeden tento modul vypnutý.

Objektivní vyhodnocení

Jenda85 nám 11. ledna poslal snímky obrazovky, kdy aplikací SpeedTest měřil přenosové rychlosti. Telefon byl vždy stejně daleko od routeru, přičemž při prvním testu byl zapnuta pouze poloha, při druhém současně poloha a Bluetooth a při třetím pouze Bluetooth.

Ze snímků je patrné, že zatímco při jednom aktivním modulu se rychlost downloadu pohybovala mezi 15 a 17 Mb/s, po zapnutí obou modulů současně klesla na 3 Mb/s, tedy na méně než pětinu naměřených hodnot.

Máte problémy? Hlaste se!

Rozhodli jsme se tedy vydat tento článek, abychom nasbírali další zkušenosti, které bychom případně mohli odprezentovat výrobci. Pokud tedy máte telefon řady Xiaomi Mi A (A1, A2, A2 Lite), zkuste si nainstalovat aplikaci SpeedTest a proveďte měření:

  1. pouze při zapnuté poloze
  2. při současně zapnuté poloze a Bluetooth
  3. pouze při zapnutém Bluetooth

Budeme rádi, když se o své naměřené hodnoty podělíte v komentářích pod tímto článkem. Prosíme, uvádějte přesný model telefonu a ideálně také číslo sestavení vašeho operačního systému, které byste měli najít v nastavení v sekci O telefonu.

Projevuje se na vašem telefonu pomalá Wi-Fi při zapnutém Bluetooth a GPS?

Zdroj: čtenáři našeho blogu.

59 komentářů: „Xiaomi Mi A1: pomalá Wi-Fi při zapnutém Bluetooth a GPS?

  • 14. 1. 2019 (9:46)
    Permalink

    Dobry den,

    ja sa na mojej A1-tke doma na wifi nenalogujem vobec.Bluetooth bol vypaty. GSM som neskusal. Pred aktualizaciou vsetko slapalo bez problemov.

    Kde udělali soudruzi z NDR chybu ?

  • 14. 1. 2019 (10:28)
    Permalink

    Nemáte náhodou na WiFi routeru zapnutou funkci filtrování Mac adres?Je možné že došlo ke změně Mac adresy,jak už se řešilo jinde a proto se neprihlasite.Jinak jak už sem psal jinde a je i uvedeno výše.Problem s rychlostí WiFi mám a přetrvává v kombinaci s bluetooth a polohou…..

  • 14. 1. 2019 (11:06)
    Permalink

    Mám A2 lite a problém s wifi po aktualizaci na android pie mám. pokud mám zaplý bluetooth (což mám kvůli mi bandu stále) klesá rychlost wifi na pár megabit. Pokud bluetooth vypnu, vše se vrátí do normálu jako před aktualizací, rychlost stoupne na cca 40 megabit. Řešení s MAC adresou a modemem jsem zkoušel, ale problém je jinde.

  • 14. 1. 2019 (12:48)
    Permalink

    @Lieska
    Dobrý den,

    dělal jste po aktualizaci reset telefonu do továrního nastavení?

    Karel Kilián

  • 14. 1. 2019 (12:51)
    Permalink

    @Jiří Geršl
    Dobrý den,

    čili u Vás nehraje na Mi A2 Lite roli fakt, zda je zapnutá GPS? Stačí jen Bluetooth a jede to pomaleji? Mohl byste to, prosím, změřit?

    Karel Kilián

  • 14. 1. 2019 (16:17)
    Permalink

    Tak jsem vyzkoušel všechny kombinace. A opravdu při 2.4 GHz, zapnuté GPS a zapnuté Bluetooth se rychlost sníží. S 5 GHz takový problém nemám.

  • 14. 1. 2019 (19:26)
    Permalink

    @Karel Kilián

    V prvom rade dik za ochotu pomoc s danym problemom. Bohuzial ani factory settings ani vypnuty Bluetooth a GSM nepomohli. Doma sa na rooter 2.4 GHz nenalogujem. V robote je to v pohode, ale doma nic.

  • 14. 1. 2019 (19:38)
    Permalink

    Tak teď jsem to zkoušel změřit a nějakým pro mně záhadným způsobem se zdá, že je po problému. Přitom jsem se to snažil vyřešit hodiny a hodiny v minulých dnech, nic nepomohlo. Jediné co mně napadá, že jsem nyní udělal jinak, je, že jsem restartoval polohové služby (tedy jednoduše vypnul a zapnul). Opravdu prazvláštní…

  • 15. 1. 2019 (6:58)
    Permalink

    @PETR
    Dobrý den,

    moc díky za info. S tím 5GHz je to zajímavý poznatek.

    Karel Kilián

  • 15. 1. 2019 (7:00)
    Permalink

    @Lieska
    Dobrý den,

    a nemáte na tom routeru filtr MAC adres? Ona se totiž MAC adresa při aktualizaci mění….

    Karel Kilián

  • 15. 1. 2019 (7:03)
    Permalink

    @Jiří Geršl
    Dobrý den,

    tak to je zvláštní, protože u čtenáře, který posílal snímky obrazovky, se toto děje, i když GPS zapíná a vypíná….

    Karel Kilián

  • 15. 1. 2019 (7:53)
    Permalink

    @Karel Kilián možná se to bude chovat jinak i podle modelu.Pan Geršl má MiA2 lite a já MiA1.Je možné ,že u klasické MiA2 to bude zase jinak.To už ale spíše spekuluju.

  • 15. 1. 2019 (12:24)
    Permalink

    @Karel Kilián

    ano bol to filter MAC adresy. Dik za pomoc!

  • 15. 1. 2019 (13:50)
    Permalink

    @Lieska
    Dobrý den,

    jsem rád, že se povedlo problém vyřešit 🙂

    Karel Kilián

  • 15. 1. 2019 (13:51)
    Permalink

    @Jenda85
    Dobrý den,

    je to možné. Ale je to zvláštní, protože Mi A1 a Mi A2 Lite jsou si po hardwarové stránce hodně podobné.

    Karel Kilián

  • 15. 1. 2019 (16:49)
    Permalink

    Takze mam to taky tak,pri zapnutem bluetooth a poloze je wifi pomala. Pri vypnuti polohy uz jede dobre. U 5Ghz je to vporadku,wifi jede rychle i pri zapnutem bluetooth a poloze. Mi A1 cislo sestaveni PKQ1.180917.001.V10.0.4.0.PDHMIXM

  • 15. 1. 2019 (20:42)
    Permalink

    @Rostak
    Dobrý den,

    díky moc za potvrzení.

    Karel Kilián

  • 15. 1. 2019 (21:59)
    Permalink

    Mi A1 v10.0.4.0,
    Wifi 2,4 GHz, rychlost
    s polohou 24Mbit, poloha + bluetoth 8Mbit, s bluetoth 14Mbit.

  • 15. 1. 2019 (22:04)
    Permalink

    Samozřejmě bluetooth 🙂

  • 16. 1. 2019 (6:47)
    Permalink

    @Ren
    Dobrý den,

    díky moc. Čili i jen zapnutý BT zjevně dost silně snižuje rychlost ve Vašem případě, jak vidím.

    Karel Kilián

  • 16. 1. 2019 (15:57)
    Permalink

    I když mě osobně to netrápí, musím potvrdit, když to zaokrouhlím tak 50 / 20 / 50.

  • 16. 1. 2019 (18:24)
    Permalink

    Sice už jsem v řešení tohohle problému skeptik a nechápu, že se o něm nemluví naprosto všude, ale přesto jsem udělal testy dle zadání a samozřejmě je to stejný jako u ostatních 🙂 Osobně se obávám, že tohle je HW omezení a důvod nízké ceny Xiaomi telefonů…
    BT se prostě s Wi-fi tluče, protože jedou na stejné frekvenci. Zkoušel jsem i jiný kanály, šířku pásma a je to stejný. Wi-fi sviští normálně pouze na 5Ghz, což dává smysl 😉

    Obrázek jsem hodil sem: https://ibb.co/njFrdYg

    Taky poznamenám, že pro mě není rozdílu mezi Oreo a Pie, takhle blbě mi to jelo už předtím na Oreu.
    S pásmem vysílání já tu mám vůbec problém, protože jedu na O2 Air, což je ten domácí pevnej LTE experiment a připojení samo o sobě dovoluje routeru použít pouze 9 a 13 kanál, jinak dochází k jakýmusi konfliku s LTE a rychlost samotnýho LTE připojení jde do kytek…ještě chvíli jsem vázán, ale poté tohle dobrodrůžo zruším 😉

    P.S. Měření jsem provedl na stabilnějším připojení, aby naměřená data byla relevantní.

  • 16. 1. 2019 (18:31)
    Permalink

    @erpe
    Právě proto, že se o tom nemluví všude, o tom píšeme 🙂
    Aby bylo místo, kde se tyhle věci budou řešit a probírat.
    Teď je hlavní otázkou, jestli to bylo už s Oreem, nebo jestli se to dodupalo aktualizací na Pie.

  • 16. 1. 2019 (21:01)
    Permalink

    Je to sice asi bezpředmětné,protože nemám snímky měření v oreu,ale s jistotou můžu říci,že já na svém MiA1 sem v oreu takové problémy zdaleka neměl…..výrazného zhoršení sem si všiml až po aktualizaci na android Pie a proto sem to začal více sledovat.

  • 16. 1. 2019 (21:04)
    Permalink

    @erpe
    Nějaký smysl to dává ale proč tím není ovlivněn při měření i upload, ten je stále stejný.

  • 17. 1. 2019 (6:54)
    Permalink

    @Jenda85
    No, to by právě zase nasvědčovalo spíš tomu, že jde o softwarový problém než o vzájemné rušení.

    @erpe
    Také dobrý postřeh. Přeci jen kdyby to bylo rádiové rušení, tak to ovlivní i upload.

  • 17. 1. 2019 (6:56)
    Permalink

    @Jirka
    Dobrý den,

    díky za změření. Je zajímavé, že to dosahuje tak vysokých hodnot, jako je 20 Mbps, ale i tak je to třetina při vypnutém BT+GPS.
    Připadá mi, jako by to bylo způsobené nějakým nepovedeným přerozdělováním zdrojů.

    Karel Kilián

  • 17. 1. 2019 (9:11)
    Permalink

    Ano, máte pravdu, je zajímavý, že to neovlivňuje upload. Taky nechápu, že u mě nemá stav GPS senzoru skoro žádnej vliv, tedy minimální…u mě to významně shazuje pouze stav BT.
    Trvám ovšem na tom, že jsem stejnej problém měl už na oreu a čekal jsem, že to pie opraví…ovšem uznávám, že tu mám trochu radiotechnicky složitou situaci, když získávám konektivitu přes LTE, který posílám do domácího éteru přes wi-fi s prakticky ověřeným faktem, že se tyhle sítě často, rády a za určitých nastaveních, ovlivňujou. Mám kvůli tomu za LTE modemem i další router.
    Jelikož jsem tenhle problém měl i na oreu, tak mě právě udivuje, že se debata rozjíždí až teď. Že by to na oreu potkalo jen někoho?
    Takhle uboze se rozjely debaty na XDA – prakolébce všech vývojářů, testerů a kutilů… 🙁 Smutný…
    https://forum.xda-developers.com/mi-a1/help/wi-fi-speed-slow-connection-bluetooth-t3890135
    https://forum.xda-developers.com/mi-a1/help/significant-bug-foundbluetooth-t3878106
    https://forum.xda-developers.com/mi-a1/help/wifi-slow-bluetooh-t3851943
    https://forum.xda-developers.com/mi-a1/help/poor-wifi-speed-bluetooth-connected-t3741999
    https://forum.xda-developers.com/mi-a1/help/wifi-issue-t3771472
    V posledním vlákně se objevuje i človíček, kterej informuje o stejných problémech už na nougatu i oreu, čili to samý co u mě. Navíc další, kterej tvrdí, že má tyhle problémy i na LOS 15.1, což by mohlo znamenat, že se opravdu jedná o HW vlastnost 🙁
    Pro mě to doma zatím vyřešilo zapnutí 5GHz frekvence, ta je celkem v pohodě.
    Jo a mimochodem, přítelkyně má Redmi Note 4 s poslední aktualizací a nic takovýhohle se jí neděje 🙁
    Nevím, jestli tu tohle rozlouskneme. Když Xiaomi mlčí v kauze updatu na pie, tak těžko bude nějak reagovat na tyhle problémy 🙁 Ano, jsem skeptik.

  • 17. 1. 2019 (9:17)
    Permalink

    Technická poznámka:
    …odeslal jsem sem rozsáhlej komentář, kterej se tu neobjevil a když jsem ho chtěl odeslat znovu, dočkal jsem se protestu, že už tu ten komentář je… 😀 Tak jen kdyby se to tu neobjevilo, tak tu poznamenám, že by mělo 😀
    F5 ani CTRL+F5 nepomohlo 😀

  • 17. 1. 2019 (10:32)
    Permalink

    Erpe rozsáhlý komentář i s odkazem(výsledky měření) normálně vidím😉

  • 17. 1. 2019 (11:10)
    Permalink

    Aha tak už i ten poslední rozsáhlejší s odkazem na xda😁

  • 17. 1. 2019 (12:54)
    Permalink

    @Jenda85
    No jo, já už taky vidím oba svoje komenty 😉 Ten první se toulal někde po databázích 😉

  • 17. 1. 2019 (17:54)
    Permalink

    @erpe
    Dobrý den,

    problém s komentářem byl v některém odkazů, kvůli kterému to spadlo do spamu. Musel jsem ho schválit, což jsem také udělal.

    Karel Kilián

  • 17. 1. 2019 (18:47)
    Permalink

    @Karel Kilián
    No…myslel jsem si to 🙂 Díky 🙂

  • 18. 1. 2019 (10:51)
    Permalink

    Tak se přidávám také a stejný problém pri BT a poloze jede wifi max 5 Mb/s a při vypnutí polohy nebo BT jede na 40 Mb/s ..hrozná aktualizace …:(

  • 18. 1. 2019 (12:45)
    Permalink

    @Lukáš Zralý
    Dobrý den,

    moc díky za zpětnou vazbu. Zkusím poznatky odsud eskalovat dál.

    Karel Kilián

  • 25. 1. 2019 (15:34)
    Permalink

    Tenhle problém je i na redmi 3s, řešení jsem nikdy nenašel..

  • 25. 1. 2019 (23:40)
    Permalink

    Tento problem som mal aj na telefone Honor 7 lite. Stacilo mat zapnuty bluetooth a rychlost wifi 2,4gHz bola polovycna. Urcite to je zapricinene rovnakou frekvenciou bluetooth a wifi. Mozno bluetooth a wifi zdielaju jednu antenu. Iny model telefonu mozu mat inac riesene anteny a problem nemaju. Inac prevadzkovat wifi na 2,4 GHz nema zmysel z hladiska velkeho rusenia inymi routermi a inymi zariadeniami pracujucimi na 2,4 GHz frekvenciach. Tot moj nazor.

  • 27. 1. 2019 (21:08)
    Permalink

    @David
    Dobrý den,

    je otázkou, zda řešení existuje. Ono opravdu může jít o vzájemné rušení modulů mezi sebou.

    Karel Kilián

  • 27. 1. 2019 (21:11)
    Permalink

    @Rolfi
    Dobrý den,

    ano, shoduji se s Vaším názorem. Hlavně poté, co se ukázalo, že stejně se ty telefony chovaly i s Androidem 8 Oreo.

    Karel Kilián

  • 27. 1. 2019 (22:10)
    Permalink

    Opět se budu opakovat,ale mě na verzi Oreo jela WiFi o dost lépe než na verzi Pie.Nerikam,že tam nějaký útlum nebyl,ale ne až tak razantní jako teď(MiA1)

  • 27. 1. 2019 (22:27)
    Permalink

    @Jenda85
    Dobrý den,

    v jiném komentářovém vlákně to někdo měřil na Mi A1 s Oreem a to zpomalení bylo prakticky identické – cca na třetinu. Neříkám, že to platí vždy, ale je to přinejmenším hodné zamyšlení.

    Karel Kilián

  • 28. 1. 2019 (22:23)
    Permalink

    Dobrý deň, od aktualizácie na Android 9 mám problémy s mikrofónom. Hovoria mi, že ma je veľmi slabo a tlmene počuť .. je možné že to je spôsobené aktualizáciou alebo je problém s mikrofónom ? Ďakujem

  • 29. 1. 2019 (7:47)
    Permalink

    @Monika
    Dobrý den,

    takto těžko říci. Opravdu to může být softwarovou chybou, ale stejně tak se může jednat o souběh okolností a zrovna po aktualizaci se to projevilo. V tomto případě bych jako první doporučil provést zálohu dat. Následně udělejte obnovu zařízení do továrního nastavení, čímž telefon dostanete do stavu, jako byste ho právě rozbalila z krabičky. Pokud se jednalo o softwarovou závadu, měl by problém zmizet.
    Pokud nezmizí a bude se projevovat i po továrním resetu, lze celkem spolehlivě předpokládat, že se jedná o hardwarovou závadu. S tou doporučuji obrátit se na servis.

    Karel Kilián

  • 29. 1. 2019 (10:24)
    Permalink

    Dobrý den, prosím poraďte. Přišel jsem na další špek. Po aktualizaci přestal telefon vibrovat. Zkoušel jsem všechny možné varianty. Audio profily i bez. Vibrace mi prostě nefungují. Předtím bylo vše v pořádku. Má někdo podobný problém?

  • 29. 1. 2019 (14:58)
    Permalink

    Dobrý den, prosím poraďte. Přišel jsem na další špek. Po aktualizaci přestal telefon vibrovat. Zkoušel jsem všechny možné varianty. Audio profily i bez. Vibrace mi prostě nefungují. Předtím bylo vše v pořádku. Má někdo podobný problém?

  • 30. 1. 2019 (7:11)
    Permalink

    @Sabrin
    Dobrý den,

    podívejte se do servisního menu:
    1. Otevřete systémové nastavení.
    2. Přejděte do sekce O telefonu.
    3. Čtyřikrát rychle za sebou klepněte na položku Verze jádra.
    Tam spusťte položku Vibrator test. Bude telefon vibrovat?

    Karel Kilián

  • 30. 1. 2019 (7:16)
    Permalink

    @@Sabrin
    Dobrý den,

    už jsem Vám na tento dotaz odpovídal pod dvěma články. Není nutné ho psát pod všechny články o Mi A1, které tu máme.

    Karel Kilián

  • 2. 2. 2019 (22:17)
    Permalink

    BT vypnuto Download 33/ Upload 30.
    BT zapnuto 7,5/7,45

    Takže silně ovlivňuje i Upload.

  • 4. 2. 2019 (8:24)
    Permalink

    @Mirek
    Dobrý den,

    bohužel to vypadá na nějaký konstrukční nedostatek, protože se stejným problémem se majitelé Mi A1 potýkali i s Androidem 8 Oreo.

    Karel Kilián

  • 5. 2. 2019 (22:03)
    Permalink

    Dobrý den,
    Mám MI A1
    Sestava: PKQ1.180917.001.V10.0.4.0.PDHMIXM
    A snížené rychlost WiFi je jenom při zapnutí Bluetooth.

  • 6. 2. 2019 (7:17)
    Permalink

    @Martin
    Dobrý den,

    díky za potvrzení.

    Karel Kilián

  • 7. 2. 2019 (13:10)
    Permalink

    Dobrý den Mi a1
    Číslo sestavení
    PKQ1.180917.001.V10.0.4.0.PDHMIXM
    Také se přidávám se zapnutým bluetooth rychlost na WiFi pomalá.

  • 8. 2. 2019 (12:01)
    Permalink

    @Michal
    Dobrý den,

    děkujeme za potvrzení. Spíše ale půjde o konstrukční chybu, protože se to prý projevovalo i na starších verzích Androidu.

    Karel Kilián

  • 8. 2. 2019 (14:37)
    Permalink

    Potvrzuji pomalý wi-fi při zapnutém BT + GPS. Stačí vypnout jen jedno z toho a je to normální.
    Na Oreo jsem tuhle chybu neměl.

    Jarda

  • 8. 2. 2019 (19:21)
    Permalink

    @Jarda
    Dobrý den,

    to je právě otázka. Vypadá to, že na Oreu to bylo taky. Jeden uživatel nám to měřil a bylo to stejné.

    Karel Kilián

  • 9. 2. 2019 (12:18)
    Permalink

    Po Aktualizaci na Android 9 mi bluetooth nevidí snímací tlačítko. To stejné i kolegovy. Pc vidí, tablet vidí, Mi A1 nic.

  • 9. 2. 2019 (13:49)
    Permalink

    @Patrik
    Dobrý den,

    v takovém případě bych jako první doporučil provést zálohu dat. Následně udělejte obnovu zařízení do továrního nastavení, čímž telefon dostanete do stavu, jako byste ho právě rozbalil z krabičky. Pokud se jednalo o softwarovou závadu, měl by problém zmizet.

    Karel Kilián

Napsat komentář

Vaše emailová adresa nebude zveřejněna.